Upgrade

Upgrading DC/OS Apache Spark

Because the Spark dispatcher persists its state in ZooKeeper, upgrading the DC/OS Apache Spark package requires you to complete the following steps:

  • Remove the DC/OS Apache Spark package from ZooKeeper.
  • Uninstall your current DC/OS Apache Spark package.
  • Install the DC/OS Apache Spark upgrade.

To upgrade DC/OS Apache Spark, do the following:

  1. Navigate to http://<dcos-url>/exhibitor.

  2. Click Explorer.

  3. Delete the znode corresponding to your instance of Spark. By default, the znode instance is spark_mesos_Dispatcher.

  4. Select the Spark service from the list of Services in the DC/OS GUI and click Delete or run the following command from the DC/OS CLI:

     dcos package uninstall --app-id=<app-id> spark
    
  5. Verify that you no longer see your Spark service on the Services page.

  6. Reinstall the new Spark package by running the following command:

     dcos package install spark